Jump to content

Need ORI file for BA XR8


brenden
 Share

Recommended Posts

Hi, I am on the hunt for an ORI file for this BA XR8, the editor does not show an ORI for the tear tag A3AK & PCM MODEL ABU-251, or is there another SW version that is the same I can use ???

long story short, I'm having issues with this customers car after he attempted to knife edge his throttle body..... we have replaced the throttle body and still having the same issues as it come in with, wont idle right and keeps throwing 2 DTC's 

- Code: P1270 - Engine RPM or Vehicle Speed limiter reached

-Code: P2110 - Throttle Actuator Control System - Forced Limited RPM

it has been tuned with an STC tuner and has had the PCM replaced by another shop witch iv tried to correct, not I'm not sure on the ORI file that was used and I want to rule out the "ORI" file that's on the PCM being the issue.

 

any help would be great!  

 

I have attached the file that car come in with.

ORI AS ARRIVED.tec

Link to comment
Share on other sites

There is a file for HABN9K3 available in our file repository. This is one of a few that is a read out of a vehicle and not a true stock file from Ford however as the PHF for this strategy is not available. You can tell as there is a VIN within this file.

Looking at your file it is identical to our "stock" file though. So I would be reasonably confident it is indeed stock.

To view this file use the following.

image.png.0a25916e491625e4771f4fefbe78a988.png

image.png.36a0a977f6a9b85ff2c208abf6151049.png

There are 3 other stock files you can also compare against as well.

HABN9A3 - Auto (uses different injectors to yours)

HABN9L2 - Auto (same injectors as yours)

HABN9M2 - Manual

Link to comment
Share on other sites

Love your work roland! cheers!

 

ill have a look and see what I can do, I'm not 100% convinced it is the file on the car but we are running out of ideas and tests to do as everything is testing ok haha

Link to comment
Share on other sites

another thing we found is if we remove the MAP sensor from the manifold and block the hole for it its doesn't fail......... everything is testing like it should with our scope and we have replaced it just incase 

Link to comment
Share on other sites

Datalog the map pressure and see if its in a fault status. If it is it will read barometric pressure of 101kpa or 29 inHG

What is the spark timing when it is struggling to idle? If you have a large air leak it will peg at min timing eg -5 degrees. If the idle continues to increase with the spark pegged it will kill fuel to stop the engine over revving. This usually results in what sounds like a supercharger lope idle.

I would be betting on an airleak personally. Smoke test the intake with the throttle blade open. The fact it has been off/modified and its an old BA you probably have a split/torn seal or hose clamp somewhere.

Can you attach a datalog including spark/map/TPS etc.

Link to comment
Share on other sites

Was the motor on a stone cold start? You are idling at -10 deg timing. If it was warm you 100% you have an airleak. You need to do a proper smoke test.

If it was cold get it warm and do a proper log then showing the symptoms as that log wasn't jumping around too bad.

Link to comment
Share on other sites

yeah that was a 1st start up for the day, ill get it to temp and relog.

 

If there is an air/vac leak.... its got us stuffed where it is as we smoke tested it this morning after resealing the intake and can not find anything 

Link to comment
Share on other sites

We have replaced all VAC lines, blocked the brake booster (incase of an internal leak), new PCV, when we had the manifold and everything off we inspected it for crack's though none found, if there is a leak me or 2 of my other tec's can not find it lol.

I'm sitting here with a mate from another work shop and beer's of cause (5:30pm) lol going through all we have done and getting a 2nd set of eyes to go over it and see if he comes up with something.

as I said we have run out of idea's and have nothing more to test electrically or mechanically that we can think of.  

Link to comment
Share on other sites

Its' not ideal but i just hit the hole engine bay with our fire hose while it was idling and made no difference, I'm pretty sure if there was a leak we would of found it then. 

 

I'm gonna burn this thing hahaha 

 

 

Link to comment
Share on other sites

Put a fuel pressure gauge on it.

I'd also pull all the injectors and have them plus the rails cleaned. Seen a few 5.4s that sat in a shed for 3-4 years and rusted out internally blocking 3 injectors.

Can also try removing the O2 sensors so it runs in open loop and see what happens. If you have one bank fighting the other they do weird things.

Also check the cam timing hasn't jumped a tooth.

Clutching at straws but the negative timing and high idle is 99% of the time an air leak. I've seen leaks which don't open up until the engine starts rocking and lots of weird things. That is probably the best I can suggest remotely.

Link to comment
Share on other sites

image.png.0f12ac182b24bd5f1575cd1dcc947b8a.png

I should have checked this first but your fuel source is cylinder cut. Can you add torque source to the log as well as actual throttle angle. 

You most likely have an ETC fault triggering the cylinder cut out. I would be betting money on the air leak theory. The customer had the throttle off and everything points to this. Could the throttle be damaged or the wrong throttle? Have you tried jamming the throttle shut and seeing if it still idles? They don't have an IAC valve, so it should stall, if it doesn't then it confirms the air leak theory.

Link to comment
Share on other sites

So that begs the question if the throttle is shut how is it not stalling? I mean I've never done it on a v8 without an idle problem to compare, but it doesn't sound right that sucking/hissing sound. It sounds like something is sucking open.

Link to comment
Share on other sites

so we fixed it!!! we replaced the brand new FOMOCO perfectly testing throttle body and fixed!!!!  

 

i tested both the one that was on it and the new one and there identical.... its got me stuffed hahaha electrically there identical  

Link to comment
Share on other sites

just wanna thank you Roland to, you didn't have waste your time back and forth, we really appreciate it ! keep up the great work, your a legend 

 

side note, can you guys add a "diagnostic's"   part to the forums ? stuff like this may help a lot of people in my situation, someone may have an idea that may help or seen the problem before.

Link to comment
Share on other sites

17 hours ago, brenden said:

just wanna thank you Roland to, you didn't have waste your time back and forth, we really appreciate it ! keep up the great work, your a legend 

 

side note, can you guys add a "diagnostic's"   part to the forums ? stuff like this may help a lot of people in my situation, someone may have an idea that may help or seen the problem before.

No worries. When I need a break from programming and all the other stuff we do I don't mind coming on here for something different, the fact you could include logs and videos makes it something worth answering, sometimes we don't get a reply at all or people don't include logs and videos which usually makes it impossible to solve remotely.

If I had all the time in the world I would be happy to do more support like this as I like solving problems, issue is we rarely do have the time.

Good idea about the forum section. I'll look at adding something.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...