Jump to content
PCMTEC Forums
finnigan001

[deka 60lbs] Weird injector tuning issue

Recommended Posts

Hi Guys,

Just wondering if anyone had any ideas or has experienced the same issue as i have had.

I've recently been trying to dial in a set of 60lb dekas. Been having great success. So i thought.  Idle AFRs and WOT on point no lean tip-ins everything looked the goods.  Then by chance we happened to turn the aircon off and noticed that the AFRs would slowly but gradually run all the way down to 10:1 then rich(off the scale.) when the car was idling in neutral or park and stopped. Turn the air con back on and then the AFRs sit perfect at 14.5-15.  Also, putting the car in drive or reverse would bring the car back towards stoich.  This is happening in closed loop and open loop.

Things i've tired to remedy:

-lean out the low slope.  This did not help the idle with aircon off at all and made the car lean everywhere. Enriching the high slope to compensate at WOT helped but the car was still lean at idle in gear.

-lower offsets, while this did help a little, bringing the AFRs up to 11, obviously affected the slopes across the rev range and would not come any where near 14.7 the lower i went. 

-adjusting the breakpoint higher and lower.  Didnt seem to have any affect on the idle when stopped.

 

My testing makes me believe there is an idle fuel adjuster some where or an A/C fuel adjustment and in gear adjustment as it seems to lean out/adjust when there is load on the motor.

I feel like i'm missing part of the picture and going round in circles, chasing my tail.

PS: am using the injector data post up here and on xr6turbo... tried both scalings for 3 and 4 bar.

 

Cheers,

 

Share this post


Link to post
Share on other sites

The only thing that affects the fueling at steady state when warm is offset, low slope and high slope. There are no other settings you are missing except for digital pump shot, however this is only for transient conditions.

Assuming you spend 8 hours on this and you value your time at more than $0 an hour, it would be cheaper to buy and install new injectors than to spend time trying to dial the dekka 60s in.

edit: The only other thing that could cause you issues is a mechanical problem, eg you have a big fuel pump with a restrictive return/regulator, if your base fuel pressure is fluctuating it will be impossible to dial the injectors in correctly.

Share this post


Link to post
Share on other sites
3 hours ago, finnigan001 said:

AFRs would slowly but gradually run all the way down to 10:1 then rich(off the scale.)

 

I had a o2 sensor fail that caused that. I tried a few second hand ones I had lying around and you could see in the scanner that they were at various stages of stuffedness. Apparently they don't like rough handling so if you've dropped or banged it then get a new one.

Share this post


Link to post
Share on other sites

Puff: Cheers, that'll give me something else to test.

4 hours ago, Roland@pcmtec said:

Assuming you spend 8 hours on this and you value your time at more than $0 an hour, it would be cheaper to buy and install new injectors than to spend time trying to dial the dekka 60s in. 

Yup i am just about at that stage.  I dont mind spending time on it at the moment as its all R&D. However, if its a problem i cant solve its not going to be much help.  Havent had an issue dialing in any other injectors other then the dekas.

Thanks lads.

Share this post


Link to post
Share on other sites

Hi Darryl

Still enjoying your software and I noticed people going on about the Deka 60s a lot I have been tunning them on my territory turbo 

for the last few month and thought I would just chuck a few stories in the mix as I said it has been a few months of tuning as I have been 

fitting up a water air system with a lot of other airflow mods to correct along the way I have found that the main thing that affects the idle 

seems to be the correct 02 sensor and the Ba Bf speed density tuning map and fuel pressure as suggested by one of the other tuners on here 

the short and long term trims do very little and also the dead time is nothing but a lean out I am running the ford factory settings for injectors but with of course 

6olb deka they are all balanced.

I am running 80 psi at the regulator with the following settings with a bosch 02 sensor and I tried every brand they all failed as they foul up with soot as the heat shield 

on all of them has holes in the sides bosch does not and the bosch has a slightly different resistance which seems to cut the crazy fuel load issue

they still leaned out until I changed the following tables and it is only a small amount but it does have a dramatic effect.

With Air to water intercooling I am not going over 42deg on my cold side of the intercooler and our weather here has been over 40 some days here 

Regards Mike 

 

Screenshot (121).png

Screenshot (120).png

Share this post


Link to post
Share on other sites

Finnigan can confirm but the data I sent him for the Deka 60s seems to work well. Usually minor changes to get these to work at the stock 4 bar rail pressure.

Personally I would just use Bosch 980cc injector (Bosch 0 280 158 040) as they offer great spray pattern and are really easily dialed in.

I have attached the parameter file for those wishing to use it in PCMTec.

Deka2_StockInjectorBased.param

  • Like 3

Share this post


Link to post
Share on other sites

Definitely the go. After hours and hours of trying to dial these in and having no luck as above, i plugged that param file in and no more issues.

Only thing i needed to do was to trim the slopes a little for this car.  Couldn't be happier.

But i to would grab the Bosch 980cc's as well and have for other cars including my own.  Very easy to calibrate, performs as expected when changes are made, perfect for E85 if you ever get there and half the price of the ID1000s and only a couple hundred more than a set of dekas.  If you value your time the bosch's are definitely worth the difference.  However if you already have a set of dekas from a previous car/build then you can absolutely get them working near perfect with the file above.

Thanks again Darryl ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...