Jump to content
Roland@pcmtec

HOWTO: Ghost Cam and VCT simplification

Recommended Posts

Hey I've done this in an FG with HAEE5T4, works great with AC off and in N or P but stops when AC in turned on or in gear.  I can see from the logs the rpm isn't changing but MAP is increasing from 14/15 inHg to 20inHg and that's when the ghost cam stops.  I have tried looking for various TPS maps to see if theres an adder somewhere for load/AC.  Has anyone dialled this with an FG or am I using the wrong OS?  I have the professional version.

Share this post


Link to post
Share on other sites

It controls idle to rpm used a closed loop airflow and spark controller. So when you turn on the AC the idle drops, this makes the airflow controller kick in and give more airflow which then increases idle back to the setpoint. You'll see that the TPS and the load increases when this happens. To make the car still chop when this happens you need to datalog the TPS and load making sure the cam timing tables have overlap at these two values.

Share this post


Link to post
Share on other sites
On 7/31/2018 at 2:23 PM, Roland@pcmtec said:

uF22

I have an FG Mk1 Manual N/A, code HAEDJC5. Ive got the ghost cam intermittently working after following this thread and playing around with it for a few hours, it works 1/2 the time the engine is running and cuts in and out of the ghost cam  and i cant figure out why, and when it does cut out it sounds like a misfire not normal idle. I've attached my tune if anyone has any ideas. Thanks in advance

Ghost cam #2.tec

Share this post


Link to post
Share on other sites

You may have to extend the max overlap table auF0116, log A/D counts, it may be going over 10 A/D counts

 

Share this post


Link to post
Share on other sites

Hi there.

We've got a barra converted patrol, running fg turbo motor with the ZF. For some reason after copying over the parameter file, it works perfectly for about 15 seconds, changes spark source from base to idle and after that it seems to smooth itself out and stay on idle spark source. If we give the slightest throttle opening it works perfectly again, but the second you take your foot off the accelerator, the cams no longer overlap, and the idle smooths itself out again in a few seconds. If anyone has any idea that could help, it would be much appreciated. I can post a datalog if you would like, just let me know what pids you would like to see.

 

Thank you!

Share this post


Link to post
Share on other sites

Sounds like the camshaft enable/disable setpoints are not being set. Can you confirm they are both (auF1079  auF1079 set to -1000 ?

Share this post


Link to post
Share on other sites

Hi mate, i'm a bit of a novice myself but give that a try, i think it was probably coming out of the load values for the overlap in the overlap table and i changed the idle up a bit and overlap angle to 35 degrees 

969498711_load1ghostcam.tec

Share this post


Link to post
Share on other sites

alright thats the closest one so far, it pretty much worked except when warming up it kept switching between cam source 2 and 3. but i should be able to work with that. thanks so much yamonda

Share this post


Link to post
Share on other sites

Hi everyone, iv got a customer in that is complaining about his ghost cams " stumbling " and stalling at times when coming to a stop, has anyone come across this ?  

 

not the best video of the stumbling sorry 

 

is an FG mk1 xr6t manual 2010

Share this post


Link to post
Share on other sites

Turn off LTFT when the ghost cams are enabled, this requires that your fuel injectors are dialed in within 5% with the ghost cam is disabled. Then make sure you lean it out at idle via the overlap SD adder so that it isn't pig rich. Finally I recommend setting up the camshaft timing rpm breakpoints so that at 500-600 you run -30 overlap (a reverse ghost cam). This will make the rpm kick back up if it starts to stall.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...