Jump to content

DSC FAULT 2008 FG NA+T


cars.shyne@gmail.com
 Share

Recommended Posts

Afternoon all, so I’ve recently converted my 2008 fg to na+t and zf6 and created a file using the stock na tune and merge function, while successful in doing so and safe enough to drive to the tuner not far away (afr wise) I have a dsc fault that pops up not long after driving, in one instance I’d just left the drive when it sounded like the abs kicked in for a second on the passenger front and disappeared then the dsc fault appeared. I tried to change the abs calibration with forscan which actually makes the dash light up like a Xmas tree so returned it to stock. 
I still have much to learn here so any info much appreciated. 
I have been through many posts on this subject but none helpful to me at least that I understand!

Link to comment
Share on other sites

2 hours ago, cars.shyne@gmail.com said:

Afternoon all, so I’ve recently converted my 2008 fg to na+t and zf6 and created a file using the stock na tune and merge function, while successful in doing so and safe enough to drive to the tuner not far away (afr wise) I have a dsc fault that pops up not long after driving, in one instance I’d just left the drive when it sounded like the abs kicked in for a second on the passenger front and disappeared then the dsc fault appeared. I tried to change the abs calibration with forscan which actually makes the dash light up like a Xmas tree so returned it to stock. 
I still have much to learn here so any info much appreciated. 
I have been through many posts on this subject but none helpful to me at least that I understand!

Have you had a read through 

 

Link to comment
Share on other sites

  • 1 month later...

@jakka351I originally changed the config to fg turbo, (not the as built data) That lit up the dash like a Xmas tree so I put it back to xr6. That being said I’m unsure what the car was in factory form as when I got it the car was gutted for the most part, it did have an xr6 cluster in it however so I assumed it was an xr6 but I also am aware that cluster changes are often made. 
today I replaced the clock spring as I keep getting steering wheel misalignment error but that did nothing unfortunately.  
I’ve also flashed the stock as built data from here saving my previous file and it was good for about 1km until I made a hard right turn at very low speed and the abs started kicking in. 
I’m now at a loss! 

Link to comment
Share on other sites

If you get the VIN/rego and bang it into the Ford service page that should tell you what is was from factory. Did this car have an engine in it when you got it? It could be an Xr8, with the engine and bonnet missing they are essentially the same,

Link to comment
Share on other sites

Also, the steering column might have been disconnected at some stage and not replaced in correct alignment with the steering rack causing the traction control to do weird things when turning corners. The TC thinks the back end is sliding out and tries to correct for it.

I had this happen when my extractors were fitted on my XR8.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...