Jump to content

Recommended Posts

Hey guys new to pcmtec and the forum. 

I have a b series xr6 turbo, with the ghost cams strategy from a typhoon, I'm having an issue with the idle as soon as I turn on the air con, the car idles louder, but then decides throw engine light and stall. Take the aircon out of the issue and the ghost cams sound on point, I know just dont use the air con right? I have kids so my aircon Is a must for summer. 

I'm loving the ghost cam feature so thumbs up to that, so if anyone can shed some light on this issue would be much appreciated 

 

JET40T

Link to post
Share on other sites
5 minutes ago, JET40T said:

He said he was having issues with finding addons tables to correct it anything you could suggest ? Or same reply as above

You need to read the DTC code. It could be an airflow limit, or throttle limit at idle etc. The BA F6 doesn't have the extra cam timing fuel adjustments as it was the first vehicle with VCT. You can still make it work, it just needs a bit more love. You can do what we do here which is essentially a catch for if it starts to stall, it kicks the cams back to normal position very quickly.

As you can see, ghost cam idle at 900rpm, then if it drops for any reason to 600 (below idle speed) it will kick the cams back to a normal position very quickly.

image.png.d3b707354959515afa5ad9c143a0a2ec.png

The stalling sounds like a different issue though. Likely a throttle limp mode etc due to the extra throttle required at idle. I'm sure with some datalogging the problem can be resolved.

Link to post
Share on other sites
53 minutes ago, Roland@pcmtec said:

You need to read the DTC code. It could be an airflow limit, or throttle limit at idle etc. The BA F6 doesn't have the extra cam timing fuel adjustments as it was the first vehicle with VCT. You can still make it work, it just needs a bit more love. You can do what we do here which is essentially a catch for if it starts to stall, it kicks the cams back to normal position very quickly.

As you can see, ghost cam idle at 900rpm, then if it drops for any reason to 600 (below idle speed) it will kick the cams back to a normal position very quickly.

image.png.d3b707354959515afa5ad9c143a0a2ec.png

The stalling sounds like a different issue though. Likely a throttle limp mode etc due to the extra throttle required at idle. I'm sure with some datalogging the problem can be resolved.

Ok managed to changed the setting with aircon on car idles alot nicer now doesnt stall then problem now is when ac is on its raised rpm by 100 but wont ghost cam with aircon turned on only off. 

 

Cheers in advanced 

Link to post
Share on other sites
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...