Jump to content

Ba xr6t auto, to full manual btr


Recommended Posts

Use a manual calibration, then compare and copy over the idle airflow and dashpot from the auto file so you get the same throttle behaviour. (there is more than just this, but this is where I would start) 

Or do the reverse, take the original auto file and compare it to a manual disabling the various system switches and codes to effectively make it a manual car. 

Depending on which version of pcmtec you have you may not be able to see all the differences so the second option may be easier. 

Comparing an auto to manual file in the calibration list will give you some clues and help you get started. 

There are a few people on here who may have already done this who can assist. 

  • Thanks 1
Link to comment
Share on other sites

  • 2 months later...
  • 3 weeks later...
On 10/23/2022 at 12:53 PM, lol68u said:

I did the same swap

Switched auf1013 from 1 to 0

No limp mode

2003 na xr6 btr to 5 speed conversion. Ok yep, no limp mode. works great, even shows what gear it's in. box came from a donor xr6 don't know what year?

Ok, the check engine light comes on, did a reset on forscan said pats fault. disabled pats, no change. possibly park switch?

also cruise control doesn't work. It's a mate's car and I asked if he hooked up the clutch pedal switch, to which he said ' Yes'. 

Other than that, works fine.

Any ideas on the check engine light and cruise control?

regards Graham. 

Link to comment
Share on other sites

10 hours ago, Plumbs said:

2003 na xr6 btr to 5 speed conversion. Ok yep, no limp mode. works great, even shows what gear it's in. box came from a donor xr6 don't know what year?

Ok, the check engine light comes on, did a reset on forscan said pats fault. disabled pats, no change. possibly park switch?

also cruise control doesn't work. It's a mate's car and I asked if he hooked up the clutch pedal switch, to which he said ' Yes'. 

Other than that, works fine.

Any ideas on the check engine light and cruise control?

regards Graham

Hi Graham, I usually recommend that a manual strategy is used straight up. It saves having to manually update switch settings, dashpot etc.

A PATS fault shouldn't trigger the check engine light. There has to be other codes to trigger the light.

Cruise not working could be related to other switch settings.
Was cruise working before the conversion?
Does "CRUISE" display on the cluster when?

Check cruise, clutch & brake switch operation using FORScan.

  • Like 1
Link to comment
Share on other sites

10 hours ago, Plumbs said:

Hi I found auf1309.  Enable inferring of neutral from ISC state. (For clutch switch only packages). is this something that should be turned on?

From memory, it is set to 0 in a na & 1 in turbo strategies

  • Like 1
Link to comment
Share on other sites

10 hours ago, Plumbs said:

Any ideas on the check engine light and cruise control?

Just thinking about the cruise again....I remember reading somewhere that some NA pcm's are missing the clutch switch driver but I've not confirmed it.

  • Like 1
Link to comment
Share on other sites

1 hour ago, Bill said:

Hi Graham, I usually recommend that a manual strategy is used straight up. It saves having to manually update switch settings, dashpot etc.

A PATS fault shouldn't trigger the check engine light. There has to be other codes to trigger the light.

Cruise not working could be related to other switch settings.
Was cruise working before the conversion?
Does "CRUISE" display on the cluster when?

Check cruise, clutch & brake switch operation using FORScan.

Apparently the cruise was working beforehand. But this car had been sitting for a while. The cruise is displayed and the switch is on in the vid block . I’ve told them to check the brake lights and brake switch . I think it’s more of a hardware issue. Thanks Bill for your comments . Regards Graham. 
Ps only have enthusiast version.

  • Like 1
Link to comment
Share on other sites

Hi all, Thanks Bill for your help. Next week we will load in the manual Strategy's. He lives in the next town, just very hard when u live several hours away from a city and also a young Feller with not much resources like us older blokes. We shall call the young bloke W for now. But he was told by mechanics that it was impossible to change a btr to a 5 speed (not sure if it's a t5 or t56); and you can see why?

I'm hopefully going to crack this, (with the help of others, and posts results here for others, obviously, as I'm just a plumber, lol!)

I'm getting the owner to take a pic of the fault codes. W, told me that when he is in 5th and its in decel spark backing off. The engine light goes from solid to flashing !??.

Also doesn't have reverse lights. if anyone knows the wires to cut and shut that would be great. Meanwhile, I'll search the forum.

Other than that, you should have seen the smile on his face when we W, at the very least able to get it out of limp mode and he could drive it home! That was worth it. Hopefully we can fix the rest of the few issues?!!

Shall keep ya all posted! regards Graham.

Link to comment
Share on other sites

49 minutes ago, Plumbs said:

Hi all, Thanks Bill for your help. Next week we will load in the manual Strategy's. He lives in the next town, just very hard when u live several hours away from a city and also a young Feller with not much resources like us older blokes. We shall call the young bloke W for now. But he was told by mechanics that it was impossible to change a btr to a 5 speed (not sure if it's a t5 or t56); and you can see why?

T5 is a 5 speed & t56 is 6 speed. Big difference in $$ & there'll be a few more issues to deal with to get cruise working. MTX min & max values need to be correct. Diff ratio plays a part in this too.

53 minutes ago, Plumbs said:

I'm getting the owner to take a pic of the fault codes. W, told me that when he is in 5th and its in decel spark backing off. The engine light goes from solid to flashing !??.

This should be sorted with the manual strategy but getting codes will also show other possible issues.

54 minutes ago, Plumbs said:

Also doesn't have reverse lights. if anyone knows the wires to cut and shut that would be great. Meanwhile, I'll search the forum.

Red black & white red wires at the trans plug

image.png

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...