Jump to content

FG 5 Speed diff change now no cruise


JMSMotorsport
 Share

Recommended Posts

Having some trouble with a 2009 FG XR6 With the 5 speed trans, have modified the VID block to correct speedo after diff gear change. Now cruise comes up and just flashes, I have speed control enabled, Speed control source - VRS Via Wire and Speed control type - Non Intergrated. This stopped the cruise flashing and now sets but it won’t hold it tries to then just turns off. Mind you this is on a dyno so could that be because the front wheels aren’t moving? Or should it be set up different? 

Link to comment
Share on other sites

15 hours ago, JMSMotorsport said:

Well might have found a problem. FG with complete BA rear cradle so had adapted BA ABS Sensor to FG plug. Except now I get a ABS fault not coherent abs sensors left and right rear. Is there any where to alter the sensor calibration data to suit BA sensors?

I doubt it. You'll need the original sensors. You could try comparing the ABS asbuilt data in forscan between an FG and BA to see if its configurable, but it is unlikely.

You'll always get an ABS fault when on the dyno as well.

Link to comment
Share on other sites

On 9/4/2020 at 9:54 AM, JMSMotorsport said:

Funny thing is no ABS fault on dyno, took it off to see if that was issue with cruise. Cruise stopped flashing but then triggered the ABS fault. Looks like I will have to make some form of adapter for the FG sensor into BA cradle. 

I can't remember the exact reason but i have read somewhere that BA sensor won't work in FG & visa versa. Might have been something to do with the pattern of the signal ie one uses square wave, the other doesn't

  • Thanks 1
Link to comment
Share on other sites

6 minutes ago, JMSMotorsport said:

Managed to get it sorted. Made a plug that fits The BA cradle on outside and FG sensor inside and spaced out with a thick washer. Had to change the speed control to ABS CAN and intergrated control. 

I just read you're response & thought....Shouldn't it have been either ABS CAN or TCS CAN already? I then had to read from your initial post again & saw the reference to VRS Via Wire....that should have also been a trigger for issues.

Good to hear you've got it sorted

Link to comment
Share on other sites

Just now, Bill said:

I just read you're response & thought....Shouldn't it have been either ABS CAN or TCS CAN already? I then had to read from your initial post again & saw the reference to VRS Via Wire....that should have also been a trigger for issues.

Good to hear you've got it sorted

When I first connected and downloaded the stock file it was set for VRS via wire and control was undefined. Must be a glitch when it first gets the VID block data. 

Link to comment
Share on other sites

1 minute ago, JMSMotorsport said:

When I first connected and downloaded the stock file it was set for VRS via wire and control was undefined. Must be a glitch when it first gets the VID block data. 

VID block in the original PCM file should have been correct but stock PCMtec files need to have the VID block merged from the original PCM file either using the merge function or manually.

Link to comment
Share on other sites

13 hours ago, JMSMotorsport said:

When I first connected and downloaded the stock file it was set for VRS via wire and control was undefined. Must be a glitch when it first gets the VID block data. 

There is no "stock" VID block. The standard settings are entirely blank in the stock files as this is dependent on how the car was optioned. When you do "Create and merge" it will merge in your VID block into the stock file. So in this case it sounds like the file you read our of the vehicle had been set up incorrectly.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...