Jump to content

ZF tuning with aftermarket PCM


Recommended Posts

Has anyone successfully logged the ZF transmission live data with PCMTec when using an aftermarket PCM ? 

 

Reading and writing to the TCM etc works as per normal but really need the live data.

 

Cheers 

Link to comment
Share on other sites

Posted (edited)
On 8/5/2023 at 11:17 PM, Roland@pcmtec said:

What is the problem with datalogging?

In this case im Running a haltech pcm but still use pcmtec to tune the tcm. Assuming I need a ford pcm for the trans data to be logged successfully .

 

Thanks .

Edited by overlap
Link to comment
Share on other sites

9 hours ago, overlap said:

In this case im Running a haltech pcm but still use pcmtec to tune the tcm. Assuming I need a ford pcm for the trans data to be logged successfully .

Thanks .

You should be able to datalog the TCM separately by clicking the trans button in the datalogger. You wouldn't be the first to do this.

Link to comment
Share on other sites

On 8/8/2023 at 2:08 PM, Roland@pcmtec said:

You should be able to datalog the TCM separately by clicking the trans button in the datalogger. You wouldn't be the first to do this.

If it is possible there must be more to it? . If no pcm is detected the "trans" button is not selectable in the logger. 

Link to comment
Share on other sites

17 minutes ago, overlap said:

If it is possible there must be more to it? . If no pcm is detected the "trans" button is not selectable in the logger. 

Open a stock file & then start the datalogger

  • Like 1
Link to comment
Share on other sites

6 hours ago, overlap said:

If it is possible there must be more to it? . If no pcm is detected the "trans" button is not selectable in the logger. 

It looks like it was disabled as there was confusion with people not knowing to connect to the PCM and TCM separately. Now the datalogger automatically connects to the PCM+TCM in one go. As a result of us combining the connect functionality you cannot click the TCM connect button without an OEM PCM being detected.

Haltech did originally propose to emulate a PCM for use with our software, but they did not decide to go ahead with this so we did not implement it.

You'll have to use something else to datalog the TCM. Or tie the stock PCM back in on the CAN network, I'm not sure how that will go but it might work.

Being as we don't charge credits for the ZF licensing/datalogging, we are not likely to make any changes here. There might be some hacks to get the TCM button to show up, like connecting to a PCM+TCM on the bench and then hot swapping it, or maybe trying to open a PCM file and use the table trace function. If this works it is not by design, rather a bug that might work.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...