Jump to content
Milanski

FG MKII ZF6 to Manual Conversion

Recommended Posts

Hi everyone, looking for some help.  Before proceeding, please don't ask why, I'm still shaking my head, but a workshop has asked me to help. 

They have converted a FG MKII EcoLPI to a manual.  No manual looms exist for an ECO LPI.  For now we have kept the ECU (HAEL2JF.HEX) and the wiring looms.  The can bus remains joined at the wiring loom of the ZF.  I can see communication with all major controllers (except TCM of course), so the CAN BUS is working.

At ignition lights, "transmission fault" fault appears.  I have followed numerous topics from PCMTEC to set various parameters:

DTC Control P07xx = NO ERROR to all related to transmission

auF1013 - Auto TRNS switch = 0

auF1625 - Transmission control strategy to be executed = 0   <------- what should this number be, it was 4.  

auF2240 - Used to indicate what sensors are available to infer transmission load state, especially neutral. See strategy book for options = 2.  Is there a strategy book? What should this value be?

VID Block

Speed control enabled = enabled

Speed control source - VSS source = ABS via CAN

 

I cannot seem to get rid of the Transmission fault alarm on the dash.

I will be wiring the PNS input of the ecu today to remove the "Transmission not in Park" signal, so i get spark.  

The manual ECU version for the FG does not utilise the EEC-C connector at all, but the EcoLPI has some wires there.  I am working through the drawing to identify what EEC-C actually does on the LPI.  

Any help is appreciated and will be reciprocated.  

 

 

Share this post


Link to post
Share on other sites

Quick update:

Conversion has been a success and the car runs fine.  I just cant seem to get rid of the transmission fault on the dash.  Anyone have any ideas?

Share this post


Link to post
Share on other sites

Is there anyway to remove the U0402 code?

Seems like the abs wants to communicate with the tcm which is no longer available.  

Abs come up ids as well as forescan.  

Is there are parameter in the editor that can turn this MIL off.  

 

Milan.

Share this post


Link to post
Share on other sites

It isn't as simple as just turning off a code, you have to tell all the other modules that the vehicle is now a manual which is not trivial as the problem has nothing to do with the PCM, the dash and ABS modules will need reprogramming at a minimum. Have a chat to Whiteford, he can sort you out for this and is in VIC.

https://www.facebook.com/WhitefordTech

Share this post


Link to post
Share on other sites

If only it was that easy.  I have talked with bpr as well and we have come as far we can.  The fg ecolpi didnt come in manual and hence there is no access to the "transaxle" parameter.  May have to replace the abs module with manual version as they are self configuring and dont appear in the ids system.

Share this post


Link to post
Share on other sites
18 hours ago, Milanski said:

If only it was that easy.  I have talked with bpr as well and we have come as far we can.  The fg ecolpi didnt come in manual and hence there is no access to the "transaxle" parameter.  May have to replace the abs module with manual version as they are self configuring and dont appear in the ids system.

Apparently Forscan can change the ABS as built data in some cases. Best option will be to just get a manual ABS module though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...